Ansible-galaxy roles install throws “List index out of range”

This is an annoyingly badly printed error message. It just means that the directory you are trying to install to isn’t accessible to ansible-galaxy. You should be able to fix it by using one (or more, as the case may be) of the following:

  1. -p, --roles-path to specify where your roles should install to,
  2. Edit ansible.cfg for the default roles location,
  3. chown -R you:you /your/role/directory

Devops DBA. This blog chronicles my “gotcha” moments — Each post contains an answer I would have like to have found when searching for those pesky errors I get.